CentOS8からOracleLinux8に移行する手順

少し前の話になりますが、CentOS8の開発が2021年末で終了することが発表されました。サポートも含め、突然2021年末で終了するとのことで、大騒ぎになったことは記憶に新しいです。

今後、CentOSはCentOS Streamというものに一本化されるとのことですが、これはRed Hat Enterprise Linux(RHEL)のプレリリース版のようなものだということで、安定版として使うにはちょっと厳しい。

そんな訳で、安定版として使用でき、サポートも(契約すれば)利用できる、RHELクローンのディストリビューション「Oracle Linux 8」に移行してみるべく、手順をメモメモ。

作業前には、バックアップを取っておくことを強く推奨。

Oracle Linuxとは

簡単に言えば、RHELのクローンで、サポートを受けなければ無料で使用できるディストリビューションです。開発環境だけでなく、本番環境でも無料で使用できます。

長ったらしい説明は省略します。詳しくはOracle Linuxのサイトをどうぞ!

Oracle Linuxへの移行

最初に、CentOSからの移行についての公式ページに目を通しておきましょう。

Oracle Linuxへの移行は、専用のシェルスクリプトをダウンロードして実行します。GitHubのOracleのページに必要な情報がありますので、以下のリンク先へ。

「Switch from CentOS to Oracle Linux」という見出しの「Usage」というセクションに、手順が書かれています。

移行手順

まずは、CentOS Linux 6,7,8のいずれかから、centos2ol.shをダウンロードします。今回はCentOS8を対象にメモしています。

サイトのリンクからダウンロードしてもいいですが、ダウンロードコマンドで直接ダウンロードした方が楽です。

# curl -O https://raw.githubusercontent.com/oracle/centos2ol/main/centos2ol.sh

ダウンロードしたファイルをrootユーザーで実行します。

# bash centos2ol.sh

Oracle Linuxへの移行に必要なパッケージがインストールされます。

途中でこんなメッセージが表示され停止した場合は、移行中にエラーが発生して中断されていますので、エラーの原因を探る必要があります。

An error occurred while attempting to switch this system to Oracle Linux and it may be in an unstable/unbootable state. To avoid further issues, the script has terminated.

今回実施した環境では、上記エラーメッセージが出て処理が止まってしまいました。原因は、スクリプト内で $old_release の値が空になっていたから。$old_releaseには、

rpm -q --whatprovides /etc/redhat-release

の結果がセットされますので、「Backing up and removing old repository files...」というメッセージを出力する処理の直後に、$old_releaseの値をセットし直してあげたところ、正常に処理が進むようになりました。

# bash centos2ol.sh
Checking for required packages...
Checking your distribution...
epel-release-8-7.el8.noarch
Checking for yum lock...
Checking for required python packages...
Identifying dnf modules that are enabled
Finding your repository directory...
Learning which repositories are enabled...
Repositories enabled before update include:
AppStream
BaseOS
extras
elrepo
remi-modular
remi-safe
ol8_baseos_latest
ol8_appstream
ol8_UEKR6
Looking for yumdownloader...
Backing up and removing old repository files...
Removing CentOS-specific yum configuration from /etc/yum.conf
Downloading Oracle Linux release package...
Oracle Linux 8 BaseOS Latest (x86_64)                                                                       7.9 kB/s | 2.7 kB     00:00
Oracle Linux 8 Application Stream (x86_64)                                                                   51 kB/s | 3.1 kB     00:00
Latest Unbreakable Enterprise Kernel Release 6 for Oracle Linux 8 (x86_64)                                   36 kB/s | 2.5 kB     00:00
(1/3): oraclelinux-release-el8-1.0-15.el8.x86_64.rpm                                                        282 kB/s |  18 kB     00:00
(2/3): redhat-release-8.3-1.0.0.1.el8.x86_64.rpm                                                            189 kB/s |  17 kB     00:00
(3/3): oraclelinux-release-8.3-1.0.4.el8.x86_64.rpm                                                         380 kB/s |  71 kB     00:00
Switching old release package with Oracle Linux...
Enabling ol8_appstream which replaces AppStream
Enabling ol8_baseos_latest which replaces BaseOS
Installing base packages for Oracle Linux...
Oracle Linux 8 BaseOS Latest (x86_64)                                                                        45 kB/s | 2.7 kB     00:00
Oracle Linux 8 Application Stream (x86_64)                                                                   48 kB/s | 3.1 kB     00:00

~ 中略 ~

アップグレード済み:
  abrt-2.10.9-20.0.1.el8.x86_64                                             abrt-addon-ccpp-2.10.9-20.0.1.el8.x86_64
  abrt-addon-coredump-helper-2.10.9-20.0.1.el8.x86_64                       abrt-addon-kerneloops-2.10.9-20.0.1.el8.x86_64
  abrt-addon-pstoreoops-2.10.9-20.0.1.el8.x86_64                            abrt-addon-vmcore-2.10.9-20.0.1.el8.x86_64
  abrt-addon-xorg-2.10.9-20.0.1.el8.x86_64                                  abrt-cli-2.10.9-20.0.1.el8.x86_64
  abrt-dbus-2.10.9-20.0.1.el8.x86_64                                        abrt-libs-2.10.9-20.0.1.el8.x86_64
  abrt-tui-2.10.9-20.0.1.el8.x86_64                                         grub2-common-1:2.02-90.0.2.el8_3.1.noarch
  grub2-pc-1:2.02-90.0.2.el8_3.1.x86_64                                     grub2-pc-modules-1:2.02-90.0.2.el8_3.1.noarch
  grub2-tools-1:2.02-90.0.2.el8_3.1.x86_64                                  grub2-tools-efi-1:2.02-90.0.2.el8_3.1.x86_64
  grub2-tools-extra-1:2.02-90.0.2.el8_3.1.x86_64                            grub2-tools-minimal-1:2.02-90.0.2.el8_3.1.x86_64
  grubby-8.40-41.0.1.el8.x86_64                                             initscripts-10.00.9-1.el8.x86_64
  linux-firmware-999:20201016-999.6.git58d41d0f.el8.noarch                  plymouth-0.9.4-7.20200615git1e36e30.0.1.el8.x86_64
  plymouth-core-libs-0.9.4-7.20200615git1e36e30.0.1.el8.x86_64              python3-abrt-2.10.9-20.0.1.el8.x86_64
  python3-abrt-addon-2.10.9-20.0.1.el8.x86_64                               tuned-2.14.0-3.0.2.el8_3.2.noarch

インストール済み:
  kernel-uek-5.4.17-2036.104.5.el8uek.x86_64       oracle-epel-release-el8-1.0-2.el8.x86_64       oracle-logos-80.5-1.0.6.el8.x86_64

スキップ済み:
  remi-release-8.1-2.el8.remi.noarch                                   remi-release-8.3-1.el8.remi.noarch

削除しました:
  centos-logos-80.5-2.el8.x86_64
  dnf-plugin-spacewalk-2.8.5-11.module_el8.0.0+180+337688dc.noarch
  epel-release-8-7.el8.noarch
  libreport-plugin-rhtsupport-2.9.5-6.el8.x86_64
  python3-dnf-plugin-spacewalk-2.8.5-11.module_el8.0.0+180+337688dc.noarch
  python3-hwdata-2.3.6-3.el8.noarch
  python3-librepo-1.12.0-2.el8.x86_64
  python3-netifaces-0.10.6-4.el8.x86_64
  python3-newt-0.52.20-9.el8.x86_64
  python3-rhn-client-tools-2.8.16-13.module_el8.0.0+180+337688dc.x86_64
  python3-rhnlib-2.8.6-8.module_el8.0.0+180+337688dc.noarch
  python3-syspurpose-1.23.8-35.el8.x86_64
  remi-release-8.0-4.el8.remi.noarch
  rhn-client-tools-2.8.16-13.module_el8.0.0+180+337688dc.x86_64

完了しました!
メタデータの期限切れの最終確認: 0:02:03 時間前の 2021年03月22日 16時14分45秒 に実施しました。
ダウンロード済みのパッケージは、次の正常なトランザクションまでキャッシュに保存されました。
'yum clean packages' を実行することでキャッシュパッケージを削除できます。
Updating initrd...
Switch successful. Syncing with Oracle Linux repositories.
Oracle Linux 8 EPEL Packages for Development (x86_64)                                                       5.1 MB/s |  12 MB     00:02
メタデータの期限切れの最終確認: 0:00:04 時間前の 2021年03月22日 16時17分21秒 に実施しました。
エラー:
 問題: package libreport-rhel-2.9.5-6.el8.x86_64 requires libreport = 2.9.5-6.el8, but none of the providers can be installed
  - libreport-2.9.5-6.el8.x86_64 does not belong to a distupgrade repository
  - problem with installed package libreport-rhel-2.9.5-6.el8.x86_64
(インストール不可のパッケージをスキップするには、'--skip-broken' を追加してみてください または、'--nobest' を追加して、最適候補のパッケージ のみを使用しないでください)
Could not automatically sync with Oracle Linux repositories.
Check the output of 'yum distro-sync' to manually resolve the issue.
For assistance, please open an issue via GitHub: https://github.com/oracle/centos2ol/.

長々と画面のログを貼り付けてみましたが、最後の方で下記のようなメッセージが表示されて処理が終了すれば、とりあえず完了です。

Switch successful. Syncing with Oracle Linux repositories.

エラーが発生したので対策

今回、完了メッセージと共にエラーが表示されています。エラー部分を抜き出してみると、

エラー:
問題: package libreport-rhel-2.9.5-6.el8.x86_64 requires libreport = 2.9.5-6.el8, but none of the providers can be installed
- libreport-2.9.5-6.el8.x86_64 does not belong to a distupgrade repository
- problem with installed package libreport-rhel-2.9.5-6.el8.x86_64
(インストール不可のパッケージをスキップするには、'--skip-broken' を追加してみてください または、'--nobest' を追加して、最適候補のパッケージ のみを使用しないでください)
Could not automatically sync with Oracle Linux repositories.
Check the output of 'yum distro-sync' to manually resolve the issue.
For assistance, please open an issue via GitHub: https://github.com/oracle/centos2ol/.

ということです。早い話が、libreport-2.9.5-6.el8.x86_64がアップグレードできない、と言われているので、サクッと削除して新規インストールしていただきましょう。

# rpm -qa | grep libreport-rhel-2.9.5-6.el8.x86_64
libreport-rhel-2.9.5-6.el8.x86_64
# yum remove libreport-rhel-2.9.5-6.el8.x86_64
モジュラーの依存に関する問題:

 問題 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-MySQL:4.046:8010020190322121447:6bc6cad6-0.x86_64
 問題 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8030020200505125553:fbe42456-0.x86_64
依存関係が解決しました。

~ 中略 ~

削除しました:
  libreport-rhel-2.9.5-6.el8.x86_64

完了しました!

そして、改めて処理を再開してみます。

# yum distro-sync
メタデータの期限切れの最終確認: 0:10:23 時間前の 2021年03月22日 16時17分21秒 に実施しました。
依存関係が解決しました。

~ 中略 ~

アップグレード済み:
  NetworkManager-1:1.26.0-13.0.1.el8_3.x86_64                           NetworkManager-config-server-1:1.26.0-13.0.1.el8_3.noarch
  NetworkManager-libnm-1:1.26.0-13.0.1.el8_3.x86_64                     NetworkManager-libreswan-1.2.10-4.el8.x86_64
  NetworkManager-team-1:1.26.0-13.0.1.el8_3.x86_64                      NetworkManager-tui-1:1.26.0-13.0.1.el8_3.x86_64
  PackageKit-1.1.12-6.0.1.el8.x86_64                                    PackageKit-glib-1.1.12-6.0.1.el8.x86_64
  adcli-0.8.2-7.el8.x86_64                                              annobin-9.23-1.el8.x86_64
  apr-1.6.3-11.el8.x86_64                                               audit-3.0-0.17.20191104git1c2f876.el8.x86_64
  audit-libs-3.0-0.17.20191104git1c2f876.el8.x86_64                     augeas-libs-1.12.0-5.el8.x86_64
  authselect-1.2.1-2.el8.x86_64                                         authselect-compat-1.2.1-2.el8.x86_64
  authselect-libs-1.2.1-2.el8.x86_64                                    autofs-1:5.1.4-43.0.1.el8.x86_64
  bash-4.4.19-12.el8.x86_64                                             bind-export-libs-32:9.11.20-5.el8_3.1.x86_64
  bind-libs-32:9.11.20-5.el8_3.1.x86_64                                 bind-libs-lite-32:9.11.20-5.el8_3.1.x86_64
  bind-license-32:9.11.20-5.el8_3.1.noarch                              bind-utils-32:9.11.20-5.el8_3.1.x86_64
  binutils-2.30-79.0.1.el8.x86_64                                       blktrace-1.2.0-10.el8.x86_64
  bolt-0.9-1.el8.x86_64                                                 boost-atomic-1.66.0-10.el8.x86_64
  boost-chrono-1.66.0-10.el8.x86_64                                     boost-date-time-1.66.0-10.el8.x86_64
  boost-regex-1.66.0-10.el8.x86_64                                      boost-system-1.66.0-10.el8.x86_64
  boost-thread-1.66.0-10.el8.x86_64                                     bpftool-4.18.0-240.15.1.el8_3.x86_64
  brotli-1.0.6-2.el8.x86_64                                             ca-certificates-2020.2.41-80.0.el8_2.noarch
  checkpolicy-2.9-1.el8.x86_64                                          chkconfig-1.13-2.el8.x86_64
  chrony-3.5-1.0.1.el8.x86_64                                           cifs-utils-6.8-3.el8.x86_64
  clevis-13-3.el8.x86_64                                                clevis-luks-13-3.el8.x86_64
  cockpit-224.2-1.0.1.el8.x86_64                                        cockpit-bridge-224.2-1.0.1.el8.x86_64
  cockpit-packagekit-224.2-1.0.1.el8.noarch                             cockpit-storaged-224.2-1.0.1.el8.noarch
  cockpit-system-224.2-1.0.1.el8.noarch                                 cockpit-ws-224.2-1.0.1.el8.x86_64
  coreutils-8.30-8.0.1.el8.x86_64                                       coreutils-common-8.30-8.0.1.el8.x86_64
  cpp-8.3.1-5.1.0.1.el8.x86_64                                          crash-7.2.8-7.0.2.el8.x86_64
  crash-gcore-command-1.5.1-1.el8.x86_64                                crash-ptdump-command-1.0.7-1.el8.x86_64
  crash-trace-command-2.0-17.el8.x86_64                                 criu-3.12-9.el8.x86_64
  cronie-1.5.2-4.el8.x86_64                                             cronie-anacron-1.5.2-4.el8.x86_64
  crypto-policies-20200713-1.git51d1222.el8.noarch                      cryptsetup-2.3.3-2.el8.x86_64
  cryptsetup-libs-2.3.3-2.el8.x86_64                                    cups-libs-1:2.2.6-38.el8.x86_64
  curl-7.61.1-14.el8_3.1.x86_64                                         cyrus-sasl-2.1.27-5.el8.x86_64
  cyrus-sasl-gssapi-2.1.27-5.el8.x86_64                                 cyrus-sasl-lib-2.1.27-5.el8.x86_64
  cyrus-sasl-plain-2.1.27-5.el8.x86_64                                  dbus-1:1.12.8-12.0.1.el8_3.x86_64
  dbus-common-1:1.12.8-12.0.1.el8_3.noarch                              dbus-daemon-1:1.12.8-12.0.1.el8_3.x86_64
  dbus-libs-1:1.12.8-12.0.1.el8_3.x86_64                                dbus-tools-1:1.12.8-12.0.1.el8_3.x86_64
  device-mapper-8:1.02.171-5.el8_3.2.x86_64                             device-mapper-event-8:1.02.171-5.el8_3.2.x86_64
  device-mapper-event-libs-8:1.02.171-5.el8_3.2.x86_64                  device-mapper-libs-8:1.02.171-5.el8_3.2.x86_64
  device-mapper-multipath-0.8.4-5.el8.x86_64                            device-mapper-multipath-libs-0.8.4-5.el8.x86_64
  device-mapper-persistent-data-0.8.5-4.el8.x86_64                      dhcp-client-12:4.3.6-41.el8.x86_64
  dhcp-common-12:4.3.6-41.el8.noarch                                    dhcp-libs-12:4.3.6-41.el8.x86_64
  diffutils-3.6-6.el8.x86_64                                            dmidecode-1:3.2-6.el8.x86_64
  dovecot-1:2.3.8-4.el8.x86_64                                          dracut-049-95.git20200804.0.4.el8_3.4.x86_64
  dracut-config-rescue-049-95.git20200804.0.4.el8_3.4.x86_64            dracut-network-049-95.git20200804.0.4.el8_3.4.x86_64
  dracut-squash-049-95.git20200804.0.4.el8_3.4.x86_64                   dyninst-10.1.0-4.el8.x86_64
  e2fsprogs-1.45.6-1.el8.x86_64                                         e2fsprogs-libs-1.45.6-1.el8.x86_64
  efi-srpm-macros-3-2.0.2.el8.noarch                                    efivar-libs-37-4.el8.x86_64
  elfutils-default-yama-scope-0.180-1.el8.noarch                        elrepo-release-8.2-1.el8.elrepo.noarch
  ethtool-2:5.0-2.el8.x86_64                                            expat-2.2.5-4.el8.x86_64
  fcoe-utils-1.0.32-7.el8.x86_64                                        file-5.33-16.el8.x86_64
  file-libs-5.33-16.el8.x86_64                                          filesystem-3.8-3.el8.x86_64
  firewalld-0.8.2-2.0.1.el8.noarch                                      firewalld-filesystem-0.8.2-2.0.1.el8.noarch
  fprintd-1.90.0-0.20191121gitf022902.el8.x86_64                        fprintd-pam-1.90.0-0.20191121gitf022902.el8.x86_64
  freetype-2.9.1-4.el8_3.1.x86_64                                       fribidi-1.0.4-8.el8.x86_64
  fuse-libs-2.9.7-12.0.3.el8.x86_64                                     fuse3-libs-3.2.1-12.0.3.el8.x86_64
  gcc-8.3.1-5.1.0.1.el8.x86_64                                          gcc-c++-8.3.1-5.1.0.1.el8.x86_64
  gcc-gdb-plugin-8.3.1-5.1.0.1.el8.x86_64                               gd-2.2.5-7.el8.x86_64
  gdb-8.2-12.0.1.el8.x86_64                                             gdb-headless-8.2-12.0.1.el8.x86_64
  gdk-pixbuf2-2.36.12-5.el8.x86_64                                      gdk-pixbuf2-modules-2.36.12-5.el8.x86_64
  gettext-0.19.8.1-17.el8.x86_64                                        gettext-common-devel-0.19.8.1-17.el8.noarch
  gettext-devel-0.19.8.1-17.el8.x86_64                                  gettext-libs-0.19.8.1-17.el8.x86_64
  git-2.27.0-1.el8.x86_64                                               git-core-2.27.0-1.el8.x86_64
  git-core-doc-2.27.0-1.el8.noarch                                      glib2-2.56.4-8.el8.x86_64
  glibc-2.28-127.0.3.el8_3.2.x86_64                                     glibc-common-2.28-127.0.3.el8_3.2.x86_64
  glibc-devel-2.28-127.0.3.el8_3.2.x86_64                               glibc-headers-2.28-127.0.3.el8_3.2.x86_64
  glibc-langpack-ja-2.28-127.0.3.el8_3.2.x86_64                         glusterfs-6.0-37.2.el8.x86_64
  glusterfs-client-xlators-6.0-37.2.el8.x86_64                          glusterfs-fuse-6.0-37.2.el8.x86_64
  glusterfs-libs-6.0-37.2.el8.x86_64                                    gmp-1:6.1.2-10.el8.x86_64
  gnupg2-2.2.20-2.el8.x86_64                                            gnupg2-smime-2.2.20-2.el8.x86_64
  gnutls-3.6.14-7.el8_3.x86_64                                          gpgme-1.13.1-3.el8.x86_64
  graphviz-2.40.1-40.el8.x86_64                                         gsettings-desktop-schemas-3.32.0-5.el8.x86_64
  gssproxy-0.8.0-16.el8.x86_64                                          gtk-update-icon-cache-3.22.30-6.el8.x86_64
  gzip-1.9-9.el8.x86_64                                                 httpd-2.4.37-30.0.1.module+el8.3.0+7816+49791cfd.x86_64
  httpd-filesystem-2.4.37-30.0.1.module+el8.3.0+7816+49791cfd.noarch    httpd-tools-2.4.37-30.0.1.module+el8.3.0+7816+49791cfd.x86_64
  hwdata-0.314-8.6.0.1.el8.noarch                                       ima-evm-utils-1.1-5.el8.x86_64
  info-6.5-6.el8.x86_64                                                 ipcalc-0.2.4-4.el8.x86_64
  iproute-5.4.0-1.0.1.el8.x86_64                                        iprutils-2.4.19-1.el8.x86_64
  ipset-7.1-1.el8.x86_64                                                ipset-libs-7.1-1.el8.x86_64
  iptables-1.8.4-15.0.1.el8_3.3.x86_64                                  iptables-ebtables-1.8.4-15.0.1.el8_3.3.x86_64
  iptables-libs-1.8.4-15.0.1.el8_3.3.x86_64                             iputils-20180629-2.el8.x86_64
  irqbalance-2:1.4.0-4.el8.x86_64                                       iscsi-initiator-utils-6.2.0.878-5.gitd791ce0.0.1.el8.x86_64
  iscsi-initiator-utils-iscsiuio-6.2.0.878-5.gitd791ce0.0.1.el8.x86_64  isns-utils-libs-0.99-1.el8.x86_64
  iwl100-firmware-999:39.31.5.1-999.6.el8.noarch                        iwl1000-firmware-999:39.31.5.1-999.6.el8.noarch
  iwl105-firmware-999:18.168.6.1-999.6.el8.noarch                       iwl135-firmware-999:18.168.6.1-999.6.el8.noarch
  iwl2000-firmware-999:18.168.6.1-999.6.el8.noarch                      iwl2030-firmware-999:18.168.6.1-999.6.el8.noarch
  iwl3160-firmware-999:25.30.13.0-999.6.el8.noarch                      iwl3945-firmware-999:15.32.2.9-999.6.el8.noarch
  iwl4965-firmware-999:228.61.2.24-999.6.el8.noarch                     iwl5000-firmware-999:8.83.5.1_1-999.6.el8.noarch
  iwl5150-firmware-999:8.24.2.2-999.6.el8.noarch                        iwl6000-firmware-999:9.221.4.1-999.6.el8.noarch
  iwl6000g2a-firmware-999:18.168.6.1-999.6.el8.noarch                   iwl6000g2b-firmware-999:18.168.6.1-999.6.el8.noarch
  iwl6050-firmware-999:41.28.5.1-999.6.el8.noarch                       iwl7260-firmware-999:25.30.13.0-999.6.el8.noarch
  jbig2dec-libs-0.14-4.el8_2.x86_64                                     jimtcl-0.77-6.el8.x86_64
  kbd-2.0.4-10.el8.x86_64                                               kbd-legacy-2.0.4-10.el8.noarch
  kbd-misc-2.0.4-10.el8.noarch                                          kernel-headers-4.18.0-240.15.1.el8_3.x86_64
  kernel-tools-4.18.0-240.15.1.el8_3.x86_64                             kernel-tools-libs-4.18.0-240.15.1.el8_3.x86_64
  kexec-tools-2.0.20-34.0.5.el8_3.2.x86_64                              kmod-25-16.0.1.el8_3.1.x86_64
  kmod-kvdo-6.2.3.114-74.0.1.el8.x86_64                                 kmod-libs-25-16.0.1.el8_3.1.x86_64
  kpartx-0.8.4-5.el8.x86_64                                             krb5-libs-1.18.2-5.el8.x86_64
  ldns-1.7.0-21.el8.x86_64                                              ledmon-0.94-1.el8.x86_64
  libICE-1.0.9-15.el8.x86_64                                            libX11-1.6.8-3.el8.x86_64
  libX11-common-1.6.8-3.el8.noarch                                      libX11-xcb-1.6.8-3.el8.x86_64
  libXau-1.0.9-3.el8.x86_64                                             libXext-1.3.4-1.el8.x86_64
  libXft-2.3.3-1.el8.x86_64                                             libXi-1.7.10-1.el8.x86_64
  libXmu-1.1.3-1.el8.x86_64                                             libXpm-3.5.12-8.el8.x86_64
  libXrandr-1.5.2-1.el8.x86_64                                          libXt-1.1.5-12.el8.x86_64
  libaio-0.3.112-1.el8.x86_64                                           libarchive-3.3.2-9.el8.x86_64
  libbabeltrace-1.5.4-3.el8.x86_64                                      libblkid-2.32.1-24.el8.x86_64
  libblockdev-2.24-2.0.1.el8_3.x86_64                                   libblockdev-crypto-2.24-2.0.1.el8_3.x86_64
  libblockdev-fs-2.24-2.0.1.el8_3.x86_64                                libblockdev-loop-2.24-2.0.1.el8_3.x86_64
  libblockdev-lvm-2.24-2.0.1.el8_3.x86_64                               libblockdev-mdraid-2.24-2.0.1.el8_3.x86_64
  libblockdev-part-2.24-2.0.1.el8_3.x86_64                              libblockdev-swap-2.24-2.0.1.el8_3.x86_64
  libblockdev-utils-2.24-2.0.1.el8_3.x86_64                             libbytesize-1.4-3.el8.x86_64
  libcap-2.26-4.el8.x86_64                                              libcap-ng-0.7.9-5.el8.x86_64
  libcom_err-1.45.6-1.el8.x86_64                                        libcomps-0.1.11-4.el8.x86_64
  libcroco-0.6.12-4.el8_2.1.x86_64                                      libcurl-7.61.1-14.el8_3.1.x86_64
  libdb-5.3.28-39.el8.x86_64                                            libdb-utils-5.3.28-39.el8.x86_64
  libdnf-0.48.0-5.0.2.el8.x86_64                                        libdrm-2.4.101-1.el8.x86_64
  libertas-usb8388-firmware-999:20201016-999.6.git58d41d0f.el8.noarch   libfdisk-2.32.1-24.el8.x86_64
  libffi-3.1-22.el8.x86_64                                              libfprint-1.90.0-4.el8.x86_64
  libgcc-8.3.1-5.1.0.1.el8.x86_64                                       libgcrypt-1.8.5-4.el8.x86_64
  libglvnd-1:1.2.0-6.el8.x86_64                                         libglvnd-glx-1:1.2.0-6.el8.x86_64
  libgomp-8.3.1-5.1.0.1.el8.x86_64                                      libgs-9.25-7.el8.x86_64
  libicu-60.3-2.el8_1.x86_64                                            libidn2-2.2.0-1.el8.x86_64
  libipa_hbac-2.3.0-9.0.1.el8.x86_64                                    libjpeg-turbo-1.5.3-10.el8.x86_64
  libkcapi-1.2.0-2.0.1.el8.x86_64                                       libkcapi-hmaccalc-1.2.0-2.0.1.el8.x86_64
  libldb-2.1.3-2.el8.x86_64                                             libluksmeta-9-4.el8.x86_64
  libmaxminddb-1.2.0-10.el8.x86_64                                      libmodulemd1-1.8.16-0.2.9.4.2.x86_64
  libmount-2.32.1-24.el8.x86_64                                         libndp-1.7-3.el8.x86_64
  libnfsidmap-1:2.3.3-35.el8.x86_64                                     libnftnl-1.1.5-4.el8.x86_64
  libnghttp2-1.33.0-3.el8_2.1.x86_64                                    libnl3-3.5.0-1.el8.x86_64
  libnl3-cli-3.5.0-1.el8.x86_64                                         libpcap-14:1.9.1-4.el8.x86_64
  libpsl-0.20.2-6.el8.x86_64                                            libreport-2.9.5-15.0.1.el8.x86_64
  libreport-cli-2.9.5-15.0.1.el8.x86_64                                 libreport-filesystem-2.9.5-15.0.1.el8.x86_64
  libreport-plugin-ureport-2.9.5-15.0.1.el8.x86_64                      libreport-web-2.9.5-15.0.1.el8.x86_64
  libreswan-3.32-7.0.1.el8_3.x86_64                                     librsvg2-2.42.7-4.el8.x86_64
  libseccomp-2.4.3-1.el8.x86_64                                         libselinux-2.9-4.el8_3.x86_64
  libselinux-utils-2.9-4.el8_3.x86_64                                   libsemanage-2.9-3.el8.x86_64
  libsepol-2.9-1.el8.x86_64                                             libsmartcols-2.32.1-24.el8.x86_64
  libsmbclient-4.12.3-14.el8_3.x86_64                                   libsoup-2.62.3-2.el8.x86_64
  libss-1.45.6-1.el8.x86_64                                             libssh-0.9.4-2.el8.x86_64
  libsss_autofs-2.3.0-9.0.1.el8.x86_64                                  libsss_certmap-2.3.0-9.0.1.el8.x86_64
  libsss_idmap-2.3.0-9.0.1.el8.x86_64                                   libsss_nss_idmap-2.3.0-9.0.1.el8.x86_64
  libsss_sudo-2.3.0-9.0.1.el8.x86_64                                    libstdc++-8.3.1-5.1.0.1.el8.x86_64
  libstdc++-devel-8.3.1-5.1.0.1.el8.x86_64                              libstoragemgmt-1.8.3-2.el8.x86_64
  libtalloc-2.3.1-2.el8.x86_64                                          libtdb-1.4.3-1.el8.x86_64
  libteam-1.31-2.el8.x86_64                                             libtevent-0.10.2-2.el8.x86_64
  libtiff-4.0.9-18.el8.x86_64                                           libtirpc-1.1.4-4.el8.x86_64
  libudisks2-2.9.0-3.el8.x86_64                                         libusbx-1.0.23-4.el8.x86_64
  libuser-0.62-23.el8.x86_64                                            libuuid-2.32.1-24.el8.x86_64
  libwbclient-4.12.3-14.el8_3.x86_64                                    libxcb-1.13.1-1.el8.x86_64
  libxkbcommon-0.9.1-1.el8.x86_64                                       libxml2-2.9.7-8.0.1.el8.x86_64
  libxslt-1.1.32-5.0.1.el8.x86_64                                       libzstd-1.4.4-1.0.1.el8.x86_64
  lldpad-1.0.1-13.git036e314.el8.x86_64                                 logrotate-3.14.0-4.el8.x86_64
  lshw-B.02.19.2-2.el8.x86_64                                           lsof-4.93.2-1.el8.x86_64
  ltrace-0.7.91-28.el8.x86_64                                           lua-libs-5.3.4-11.el8.x86_64
  luksmeta-9-4.el8.x86_64                                               lvm2-8:2.03.09-5.el8_3.2.x86_64
  lvm2-libs-8:2.03.09-5.el8_3.2.x86_64                                  lz4-1.8.3-2.el8.x86_64
  lz4-libs-1.8.3-2.el8.x86_64                                           make-1:4.2.1-10.el8.x86_64
  mariadb-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64               mariadb-backup-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64
  mariadb-common-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64        mariadb-connector-c-3.1.11-2.el8_3.x86_64
  mariadb-connector-c-config-3.1.11-2.el8_3.noarch                      mariadb-errmsg-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64
  mariadb-gssapi-server-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64 mariadb-server-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64
  mariadb-server-utils-3:10.3.27-3.module+el8.3.0+9616+7a81225f.x86_64  mcelog-3:169-0.0.1.el8.x86_64
  mdadm-4.1-14.el8.x86_64                                               mesa-libGL-20.1.4-1.el8.x86_64
  mesa-libglapi-20.1.4-1.el8.x86_64                                     microcode_ctl-4:20200609-2.20210216.1.0.1.el8_3.x86_64
  mod_http2-1.15.7-2.module+el8.3.0+7816+49791cfd.x86_64                mod_ssl-1:2.4.37-30.0.1.module+el8.3.0+7816+49791cfd.x86_64
  mokutil-1:0.3.0-10.el8.x86_64                                         mozjs52-52.9.0-2.0.1.el8.x86_64
  mtr-2:0.92-3.el8.x86_64                                               net-tools-2.0-0.52.20160912git.el8.x86_64
  nettle-3.4.1-2.el8.x86_64                                             newt-0.52.20-11.el8.x86_64
  nfs-utils-1:2.3.3-35.el8.x86_64                                       nfs4-acl-tools-0.3.5-3.el8.x86_64
  nftables-1:0.9.3-16.el8.x86_64                                        nginx-filesystem-1:1.14.1-9.0.1.module+el8.0.0+5347+9282027e.noarch
  nmap-2:7.70-5.el8.x86_64                                              nmap-ncat-2:7.70-5.el8.x86_64
  nspr-4.25.0-2.el8_2.x86_64                                            nss-3.53.1-17.el8_3.x86_64
  nss-softokn-3.53.1-17.el8_3.x86_64                                    nss-softokn-freebl-3.53.1-17.el8_3.x86_64
  nss-sysinit-3.53.1-17.el8_3.x86_64                                    nss-tools-3.53.1-17.el8_3.x86_64
  nss-util-3.53.1-17.el8_3.x86_64                                       numactl-libs-2.0.12-11.el8.x86_64
  oniguruma-6.8.2-2.el8.x86_64                                          openjpeg2-2.3.1-6.el8.x86_64
  openldap-2.4.46-15.el8.x86_64                                         openldap-clients-2.4.46-15.el8.x86_64
  openssh-8.0p1-5.el8.x86_64                                            openssh-clients-8.0p1-5.el8.x86_64
  openssh-server-8.0p1-5.el8.x86_64                                     openssl-1:1.1.1g-12.el8_3.x86_64
  openssl-libs-1:1.1.1g-12.el8_3.x86_64                                 openssl-pkcs11-0.4.10-2.el8.x86_64
  os-prober-1.74-6.0.1.el8.x86_64                                       ostree-libs-2020.7-1.el8_3.x86_64
  pam-1.3.1-11.el8.x86_64                                               pango-1.42.4-6.el8.x86_64
  parted-3.2-38.0.1.el8.x86_64                                          passwd-0.80-3.el8.x86_64
  patch-2.7.6-11.el8.x86_64                                             pciutils-3.6.4-2.el8.x86_64
  pciutils-libs-3.6.4-2.el8.x86_64                                      pcre2-10.32-2.el8.x86_64
  perl-DBD-MySQL-4.046-3.module+el8.1.0+5427+61a5d536.x86_64            perl-DBI-1.641-3.module+el8.3.0+7665+79fef143.x86_64
  perl-Data-Dump-1.23-7.module+el8.3.0+7692+542c56f9.noarch             perl-Digest-HMAC-1.03-17.module+el8.3.0+7692+542c56f9.noarch
  perl-Encode-Locale-1.05-10.module+el8.3.0+7692+542c56f9.noarch        perl-Errno-1.28-417.el8_3.x86_64
  perl-File-Listing-6.04-17.module+el8.3.0+7692+542c56f9.noarch         perl-Git-2.27.0-1.el8.noarch
  perl-HTML-Parser-3.72-15.module+el8.3.0+7692+542c56f9.x86_64          perl-HTML-Tagset-3.20-34.module+el8.3.0+7692+542c56f9.noarch
  perl-HTTP-Cookies-6.04-2.module+el8.3.0+7692+542c56f9.noarch          perl-HTTP-Date-6.02-19.module+el8.3.0+7692+542c56f9.noarch
  perl-HTTP-Message-6.18-1.module+el8.3.0+7692+542c56f9.noarch          perl-HTTP-Negotiate-6.01-19.module+el8.3.0+7692+542c56f9.noarch
  perl-IO-1.38-417.el8_3.x86_64                                         perl-IO-HTML-1.001-11.module+el8.3.0+7692+542c56f9.noarch
  perl-IO-Socket-SSL-2.066-4.module+el8.3.0+7674+5fd4be5f.noarch        perl-IO-Zlib-1:1.10-417.el8_3.noarch
  perl-LWP-MediaTypes-6.02-15.module+el8.3.0+7692+542c56f9.noarch       perl-Math-BigInt-1:1.9998.11-7.el8.noarch
  perl-Math-Complex-1.59-417.el8_3.noarch                               perl-Mozilla-CA-20160104-7.module+el8.3.0+7692+542c56f9.noarch
  perl-NTLM-1.09-17.module+el8.3.0+7692+542c56f9.noarch                 perl-Net-HTTP-6.17-2.module+el8.3.0+7692+542c56f9.noarch
  perl-Net-SSLeay-1.88-1.module+el8.3.0+7674+5fd4be5f.x86_64            perl-Socket-4:2.027-3.el8.x86_64
  perl-TimeDate-1:2.30-15.module+el8.3.0+7692+542c56f9.noarch           perl-Try-Tiny-0.30-7.module+el8.3.0+7692+542c56f9.noarch
  perl-WWW-RobotRules-6.02-18.module+el8.3.0+7692+542c56f9.noarch       perl-XML-Parser-2.44-11.0.1.el8.x86_64
  perl-generators-1.10-9.el8.noarch                                     perl-interpreter-4:5.26.3-417.el8_3.x86_64
  perl-libs-4:5.26.3-417.el8_3.x86_64                                   perl-libwww-perl-6.34-1.module+el8.3.0+7692+542c56f9.noarch
  perl-macros-4:5.26.3-417.el8_3.x86_64                                 pesign-0.112-25.0.2.el8.x86_64
  pigz-2.4-4.el8.x86_64                                                 pixman-0.38.4-1.el8.x86_64
  platform-python-3.6.8-31.0.3.el8.x86_64                               platform-python-pip-9.0.3-18.el8.noarch
  platform-python-setuptools-39.2.0-6.el8.noarch                        plymouth-scripts-0.9.4-7.20200615git1e36e30.0.1.el8.x86_64
  policycoreutils-2.9-9.0.1.el8.x86_64                                  policycoreutils-python-utils-2.9-9.0.1.el8.noarch
  polkit-0.115-11.0.1.el8.x86_64                                        polkit-libs-0.115-11.0.1.el8.x86_64
  postfix-2:3.3.1-12.el8_3.1.x86_64                                     procps-ng-3.3.15-3.el8.x86_64
  psmisc-23.1-5.el8.x86_64                                              python-srpm-macros-3-39.el8.noarch
  python3-audit-3.0-0.17.20191104git1c2f876.el8.x86_64                  python3-augeas-0.5.0-12.el8.noarch
  python3-bind-32:9.11.20-5.el8_3.1.noarch                              python3-configshell-1:1.1.28-1.0.1.el8.noarch
  python3-cryptography-2.3-3.el8.x86_64                                 python3-dbus-1.2.4-15.el8.x86_64
  python3-dmidecode-3.12.2-15.el8.x86_64                                python3-firewall-0.8.2-2.0.1.el8.noarch
  python3-gobject-3.28.3-2.el8.x86_64                                   python3-gobject-base-3.28.3-2.el8.x86_64
  python3-gpg-1.13.1-3.el8.x86_64                                       python3-hawkey-0.48.0-5.0.2.el8.x86_64
  python3-libcomps-0.1.11-4.el8.x86_64                                  python3-libdnf-0.48.0-5.0.2.el8.x86_64
  python3-libreport-2.9.5-15.0.1.el8.x86_64                             python3-libs-3.6.8-31.0.3.el8.x86_64
  python3-libselinux-2.9-4.el8_3.x86_64                                 python3-libsemanage-2.9-3.el8.x86_64
  python3-libstoragemgmt-1.8.3-2.el8.noarch                             python3-libstoragemgmt-clibs-1.8.3-2.el8.x86_64
  python3-libxml2-2.9.7-8.0.1.el8.x86_64                                python3-linux-procfs-0.6.2-2.el8.noarch
  python3-magic-5.33-16.el8.noarch                                      python3-perf-4.18.0-240.15.1.el8_3.x86_64
  python3-ply-3.9-8.el8.noarch                                          python3-policycoreutils-2.9-9.0.1.el8.noarch
  python3-requests-2.20.0-2.1.el8_1.noarch                              python3-rpm-macros-3-39.el8.noarch
  python3-rtslib-2.1.73-2.0.1.el8.noarch                                python3-schedutils-0.6-6.el8.x86_64
  python3-setools-4.3.0-2.el8.x86_64                                    python3-sssdconfig-2.3.0-9.0.1.el8.noarch
  python3-unbound-1.7.3-14.el8.x86_64                                   python3-urllib3-1.24.2-4.0.1.el8.noarch
  qt5-srpm-macros-5.12.5-3.el8.noarch                                   realmd-0.16.3-19.el8.x86_64
  redhat-rpm-config-123-1.0.1.el8.noarch                                rng-tools-6.8-3.el8.x86_64
  rpcbind-1.2.5-7.el8.x86_64                                            rsync-3.1.3-9.el8.x86_64
  rsyslog-8.1911.0-6.el8.x86_64                                         rsyslog-gnutls-8.1911.0-6.el8.x86_64
  rsyslog-gssapi-8.1911.0-6.el8.x86_64                                  rsyslog-relp-8.1911.0-6.el8.x86_64
  samba-4.12.3-14.el8_3.x86_64                                          samba-client-4.12.3-14.el8_3.x86_64
  samba-client-libs-4.12.3-14.el8_3.x86_64                              samba-common-4.12.3-14.el8_3.noarch
  samba-common-libs-4.12.3-14.el8_3.x86_64                              samba-common-tools-4.12.3-14.el8_3.x86_64
  samba-libs-4.12.3-14.el8_3.x86_64                                     samba-winbind-4.12.3-14.el8_3.x86_64
  samba-winbind-modules-4.12.3-14.el8_3.x86_64                          sed-4.5-2.el8.x86_64
  selinux-policy-3.14.3-54.0.5.el8_3.2.noarch                           selinux-policy-targeted-3.14.3-54.0.5.el8_3.2.noarch
  setroubleshoot-plugins-3.3.13-1.0.1.el8.noarch                        setroubleshoot-server-3.3.24-1.0.1.el8.x86_64
  setup-2.12.2-6.el8.noarch                                             sg3_utils-1.44-5.el8.x86_64
  sg3_utils-libs-1.44-5.el8.x86_64                                      shadow-utils-2:4.6-11.el8.x86_64
  smartmontools-1:7.1-1.el8.x86_64                                      snappy-1.1.8-3.el8.x86_64
  sos-3.9.1-6.0.3.el8.noarch                                            spamassassin-3.4.2-10.el8.x86_64
  sqlite-3.26.0-11.el8.x86_64                                           sqlite-libs-3.26.0-11.el8.x86_64
  squashfs-tools-4.3-19.el8.x86_64                                      sscg-2.3.3-14.el8.x86_64
  sssd-2.3.0-9.0.1.el8.x86_64                                           sssd-ad-2.3.0-9.0.1.el8.x86_64
  sssd-client-2.3.0-9.0.1.el8.x86_64                                    sssd-common-2.3.0-9.0.1.el8.x86_64
  sssd-common-pac-2.3.0-9.0.1.el8.x86_64                                sssd-ipa-2.3.0-9.0.1.el8.x86_64
  sssd-kcm-2.3.0-9.0.1.el8.x86_64                                       sssd-krb5-2.3.0-9.0.1.el8.x86_64
  sssd-krb5-common-2.3.0-9.0.1.el8.x86_64                               sssd-ldap-2.3.0-9.0.1.el8.x86_64
  sssd-nfs-idmap-2.3.0-9.0.1.el8.x86_64                                 sssd-proxy-2.3.0-9.0.1.el8.x86_64
  strace-5.1-1.el8.x86_64                                               sudo-1.8.29-6.el8_3.1.x86_64
  systemd-239-41.0.1.el8_3.1.x86_64                                     systemd-libs-239-41.0.1.el8_3.1.x86_64
  systemd-pam-239-41.0.1.el8_3.1.x86_64                                 systemd-udev-239-41.0.1.el8_3.1.x86_64
  systemtap-4.3-4.0.1.el8.x86_64                                        systemtap-client-4.3-4.0.1.el8.x86_64
  systemtap-devel-4.3-4.0.1.el8.x86_64                                  systemtap-runtime-4.3-4.0.1.el8.x86_64
  tar-2:1.30-5.el8.x86_64                                               target-restore-2.1.73-2.0.1.el8.noarch
  targetcli-2.1.53-1.el8.noarch                                         tcpdump-14:4.9.3-1.el8.x86_64
  teamd-1.31-2.el8.x86_64                                               telnet-server-1:0.17-74.el8_3.1.x86_64
  tigervnc-1.10.1-9.el8_3.x86_64                                        tigervnc-icons-1.10.1-9.el8_3.noarch
  tigervnc-license-1.10.1-9.el8_3.noarch                                tpm2-tools-4.1.1-1.el8.x86_64
  tpm2-tss-2.3.2-2.el8.x86_64                                           trace-cmd-2.7-8.el8.x86_64
  trousers-0.3.14-4.el8.x86_64                                          trousers-lib-0.3.14-4.el8.x86_64
  tzdata-2021a-1.el8.noarch                                             udisks2-2.9.0-3.el8.x86_64
  udisks2-iscsi-2.9.0-3.el8.x86_64                                      udisks2-lvm2-2.9.0-3.el8.x86_64
  unbound-libs-1.7.3-14.el8.x86_64                                      unzip-6.0-43.el8.x86_64
  usb_modeswitch-data-20191128-1.el8.noarch                             util-linux-2.32.1-24.el8.x86_64
  util-linux-user-2.32.1-24.el8.x86_64                                  valgrind-1:3.16.0-2.el8.x86_64
  valgrind-devel-1:3.16.0-2.el8.x86_64                                  vdo-6.2.3.114-14.el8.x86_64
  vim-common-2:8.0.1763-15.0.1.el8.x86_64                               vim-enhanced-2:8.0.1763-15.0.1.el8.x86_64
  vim-filesystem-2:8.0.1763-15.0.1.el8.noarch                           vim-minimal-2:8.0.1763-15.0.1.el8.x86_64
  volume_key-libs-0.3.11-5.el8.x86_64                                   vsftpd-3.0.3-32.el8.x86_64
  wget-1.19.5-10.0.1.el8.x86_64                                         which-2.21-12.el8.x86_64
  xfsprogs-5.4.0-1.0.1.el8.x86_64                                       xkeyboard-config-2.28-1.el8.noarch
  zlib-1.2.11-16.el8_2.x86_64                                           zsh-5.5.1-6.el8_1.2.x86_64
  zstd-1.4.4-1.0.1.el8.x86_64

インストール済み:
  boost-filesystem-1.66.0-10.el8.x86_64                                      boost-timer-1.66.0-10.el8.x86_64
  crypto-policies-scripts-20200713-1.git51d1222.el8.noarch                   jq-1.5-12.el8.x86_64
  kernel-4.18.0-240.15.1.el8_3.x86_64                                        kernel-core-4.18.0-240.15.1.el8_3.x86_64
  kernel-debug-devel-4.18.0-240.15.1.el8_3.x86_64                            kernel-devel-4.18.0-240.15.1.el8_3.x86_64
  kernel-modules-4.18.0-240.15.1.el8_3.x86_64                                libgusb-0.3.0-1.el8.x86_64
  libssh-config-0.9.4-2.el8.noarch                                           mozjs60-60.9.0-4.0.1.el8.x86_64
  python3-nftables-1:0.9.3-16.el8.x86_64                                     python3-pip-wheel-9.0.3-18.el8.noarch
  python3-pydbus-0.6.0-5.el8.noarch                                          python3-setuptools-wheel-39.2.0-6.el8.noarch
  tbb-2018.2-9.el8.x86_64

再インストール済み:
  acl-2.2.53-1.el8.x86_64                                            adobe-mappings-cmap-20171205-3.el8.noarch
  adobe-mappings-cmap-deprecated-20171205-3.el8.noarch               adobe-mappings-pdf-20180407-1.el8.noarch
  apr-util-1.6.1-6.el8.x86_64                                        apr-util-bdb-1.6.1-6.el8.x86_64
  apr-util-openssl-1.6.1-6.el8.x86_64                                asciidoc-8.6.10-0.5.20180627gitf7c2274.el8.noarch
  at-3.1.20-11.el8.x86_64                                            atk-2.28.1-1.el8.x86_64
  attr-2.4.48-3.el8.x86_64                                           autoconf-2.69-27.el8.noarch
  automake-1.16.1-6.el8.noarch                                       avahi-libs-0.7-19.el8.x86_64
  basesystem-11-5.el8.noarch                                         bash-completion-1:2.7-5.el8.noarch
  bc-1.07.1-5.el8.x86_64                                             biosdevname-0.7.3-2.el8.x86_64
  bison-3.0.4-10.el8.x86_64                                          byacc-1.9.20170709-4.el8.x86_64
  bzip2-1.0.6-26.el8.x86_64                                          bzip2-libs-1.0.6-26.el8.x86_64
  c-ares-1.13.0-5.el8.x86_64                                         cairo-1.15.12-3.el8.x86_64
  cairo-gobject-1.15.12-3.el8.x86_64                                 cgdcbxd-1.0.2-9.el8.x86_64
  clucene-core-2.3.3.4-31.20130812.e8e3d20git.el8.x86_64             cpio-2.12-8.el8.x86_64
  cracklib-2.9.6-15.el8.x86_64                                       cracklib-dicts-2.9.6-15.el8.x86_64
  crontabs-1.11-16.20150630git.el8.noarch                            ctags-5.8-22.el8.x86_64
  dbus-glib-0.110-2.el8.x86_64                                       desktop-file-utils-0.23-8.el8.x86_64
  diffstat-1.61-7.el8.x86_64                                         dnf-4.2.23-4.el8.noarch
  dnf-data-4.2.23-4.el8.noarch                                       dnf-plugins-core-4.0.17-5.el8.noarch
  docbook-dtds-1.0-69.el8.noarch                                     docbook-style-xsl-1.79.2-7.el8.noarch
  dos2unix-7.4.0-3.el8.x86_64                                        dosfstools-4.1-6.el8.x86_64
  dwz-0.12-9.el8.x86_64                                              ed-1.14.2-4.el8.x86_64
  elfutils-0.180-1.el8.x86_64                                        elfutils-debuginfod-client-0.180-1.el8.x86_64
  elfutils-libelf-0.180-1.el8.x86_64                                 elfutils-libs-0.180-1.el8.x86_64
  emacs-filesystem-1:26.1-5.el8.noarch                               findutils-1:4.6.0-20.el8.x86_64
  fipscheck-1.5.0-4.el8.x86_64                                       fipscheck-lib-1.5.0-4.el8.x86_64
  flex-2.6.1-9.el8.x86_64                                            fltk-1.3.4-5.el8.x86_64
  fontconfig-2.13.1-3.el8.x86_64                                     fontpackages-filesystem-1.44-22.el8.noarch
  gawk-4.2.1-1.el8.x86_64                                            gc-7.6.4-3.el8.x86_64
  gdbm-1:1.18-1.el8.x86_64                                           gdbm-libs-1:1.18-1.el8.x86_64
  gdisk-1.0.3-6.el8.x86_64                                           geolite2-city-20180605-1.el8.noarch
  geolite2-country-20180605-1.el8.noarch                             ghc-srpm-macros-1.4.2-7.el8.noarch
  glib-networking-2.56.1-1.1.el8.x86_64                              go-srpm-macros-2-16.el8.noarch
  gobject-introspection-1.56.1-1.el8.x86_64                          google-droid-sans-fonts-20120715-13.el8.noarch
  gpm-libs-1.20.7-15.el8.x86_64                                      graphite2-1.3.10-10.el8.x86_64
  grep-3.1-6.el8.x86_64                                              groff-base-1.22.3-18.el8.x86_64
  gtk2-2.24.32-4.el8.x86_64                                          guile-5:2.0.14-7.el8.x86_64
  hardlink-1:1.3-6.el8.x86_64                                        harfbuzz-1.7.5-3.el8.x86_64
  hdparm-9.54-2.el8.x86_64                                           hicolor-icon-theme-0.17-2.el8.noarch
  hostname-3.20-6.el8.x86_64                                         intltool-0.51.0-11.el8.noarch
  iptstate-2.2.6-6.el8.x86_64                                        isl-0.16.1-6.el8.x86_64
  jansson-2.11-3.el8.x86_64                                          jasper-libs-2.0.14-4.el8.x86_64
  jbigkit-libs-2.1-14.el8.x86_64                                     jose-10-2.el8.x86_64
  json-c-0.13.1-0.2.el8.x86_64                                       json-glib-1.4.4-1.el8.x86_64
  keyutils-1.5.10-6.el8.x86_64                                       keyutils-libs-1.5.10-6.el8.x86_64
  langpacks-ja-1.0-12.el8.noarch                                     lcms2-2.9-2.el8.x86_64
  less-530-1.el8.x86_64                                              libSM-1.2.3-1.el8.x86_64
  libXaw-1.0.13-10.el8.x86_64                                        libXcomposite-0.4.4-14.el8.x86_64
  libXcursor-1.1.15-3.el8.x86_64                                     libXdamage-1.1.4-14.el8.x86_64
  libXfixes-5.0.3-7.el8.x86_64                                       libXinerama-1.1.4-1.el8.x86_64
  libXrender-0.9.10-7.el8.x86_64                                     libXxf86misc-1.0.4-1.el8.x86_64
  libXxf86vm-1.1.4-9.el8.x86_64                                      libacl-2.2.53-1.el8.x86_64
  libappstream-glib-0.7.14-3.el8.x86_64                              libargon2-20171227-3.el8.x86_64
  libassuan-2.5.1-3.el8.x86_64                                       libatasmart-0.19-14.el8.x86_64
  libatomic_ops-7.6.2-3.el8.x86_64                                   libattr-2.4.48-3.el8.x86_64
  libbasicobjects-0.1.1-39.el8.x86_64                                libcgroup-0.41-19.el8.x86_64
  libcollection-0.7.0-39.el8.x86_64                                  libconfig-1.5-9.el8.x86_64
  libdaemon-0.14-15.el8.x86_64                                       libdatrie-0.2.9-7.el8.x86_64
  libdhash-0.5.0-39.el8.x86_64                                       libdwarf-20180129-4.el8.x86_64
  libedit-3.1-23.20170329cvs.el8.x86_64                              libestr-0.1.10-1.el8.x86_64
  libevent-2.1.8-5.el8.x86_64                                        libfastjson-0.99.8-2.el8.x86_64
  libfontenc-1.1.3-8.el8.x86_64                                      libgpg-error-1.31-1.el8.x86_64
  libgudev-232-4.el8.x86_64                                          libidn-1.34-5.el8.x86_64
  libijs-0.35-5.el8.x86_64                                           libini_config-1.3.1-39.el8.x86_64
  libipt-1.6.1-8.el8.x86_64                                          libjose-10-2.el8.x86_64
  libksba-1.3.5-7.el8.x86_64                                         libmcpp-2.7.2-20.el8.x86_64
  libmetalink-0.1.3-7.el8.x86_64                                     libmnl-1.0.4-6.el8.x86_64
  libmodman-2.0.1-17.el8.x86_64                                      libmodulemd-2.9.4-2.el8.x86_64
  libmpc-1.0.2-9.el8.x86_64                                          libnet-1.1.6-15.el8.x86_64
  libnetfilter_conntrack-1.0.6-5.el8.x86_64                          libnfnetlink-1.0.1-13.el8.x86_64
  libnsl2-1.2.0-2.20180605git4a062cf.el8.x86_64                      libpaper-1.1.24-22.el8.x86_64
  libpath_utils-0.2.1-39.el8.x86_64                                  libpciaccess-0.14-1.el8.x86_64
  libpipeline-1.5.0-2.el8.x86_64                                     libpkgconf-1.4.2-1.el8.x86_64
  libpng-2:1.6.34-5.el8.x86_64                                       libproxy-0.4.15-5.2.el8.x86_64
  libpwquality-1.4.0-9.el8.x86_64                                    libref_array-0.1.5-39.el8.x86_64
  librelp-1.2.16-1.el8.x86_64                                        librepo-1.12.0-2.el8.x86_64
  libsecret-0.18.6-1.el8.x86_64                                      libsigsegv-2.11-5.el8.x86_64
  libsolv-0.7.11-1.el8.x86_64                                        libstemmer-0-10.585svn.el8.x86_64
  libsysfs-2.1.0-24.el8.x86_64                                       libtar-1.2.20-15.el8.x86_64
  libtasn1-4.13-3.el8.x86_64                                         libthai-0.1.27-2.el8.x86_64
  libtool-2.4.6-25.el8.x86_64                                        libtool-ltdl-2.4.6-25.el8.x86_64
  libunistring-0.9.9-3.el8.x86_64                                    libutempter-1.1.6-14.el8.x86_64
  libverto-0.3.0-5.el8.x86_64                                        libverto-libevent-0.3.0-5.el8.x86_64
  libwebp-1.0.0-1.el8.x86_64                                         libxcrypt-4.1.1-4.el8.x86_64
  libxcrypt-devel-4.1.1-4.el8.x86_64                                 libxshmfence-1.3-2.el8.x86_64
  libyaml-0.1.7-5.el8.x86_64                                         lsscsi-0.30-1.el8.x86_64
  lzo-2.08-14.el8.x86_64                                             m4-1.4.18-7.el8.x86_64
  mailcap-2.1.48-3.el8.noarch                                        man-db-2.7.6.1-17.el8.x86_64
  man-pages-4.15-6.el8.x86_64                                        mcpp-2.7.2-20.el8.x86_64
  mesa-libGLU-9.0.0-15.el8.x86_64                                    mlocate-0.26-20.el8.x86_64
  mpfr-3.1.6-1.el8.x86_64                                            nano-2.9.8-1.el8.x86_64
  ncurses-6.1-7.20180224.el8.x86_64                                  ncurses-base-6.1-7.20180224.el8.noarch
  ncurses-libs-6.1-7.20180224.el8.x86_64                             npth-1.5-4.el8.x86_64
  ocaml-srpm-macros-5-4.el8.noarch                                   openblas-srpm-macros-2-2.el8.noarch
  p11-kit-0.23.14-5.el8_0.x86_64                                     p11-kit-trust-0.23.14-5.el8_0.x86_64
  patchutils-0.3.4-10.el8.x86_64                                     pcre-8.42-4.el8.x86_64
  perl-Algorithm-Diff-1.1903-9.el8.noarch                            perl-Archive-Tar-2.30-1.el8.noarch
  perl-Carp-1.42-396.el8.noarch                                      perl-Compress-Raw-Bzip2-2.081-1.el8.x86_64
  perl-Compress-Raw-Zlib-2.081-1.el8.x86_64                          perl-Crypt-OpenSSL-Bignum-0.09-5.el8.x86_64
  perl-Crypt-OpenSSL-RSA-0.31-1.el8.x86_64                           perl-Crypt-OpenSSL-Random-0.15-3.el8.x86_64
  perl-DB_File-1.842-1.el8.x86_64                                    perl-Data-Dumper-2.167-399.el8.x86_64
  perl-Digest-1.17-395.el8.noarch                                    perl-Digest-MD5-2.55-396.el8.x86_64
  perl-Digest-SHA-1:6.02-1.el8.x86_64                                perl-Encode-4:2.97-3.el8.x86_64
  perl-Encode-Detect-1.01-28.el8.x86_64                              perl-Error-1:0.17025-2.el8.noarch
  perl-Exporter-5.72-396.el8.noarch                                  perl-Fedora-VSP-0.001-9.el8.noarch
  perl-File-Path-2.15-2.el8.noarch                                   perl-File-Temp-0.230.600-1.el8.noarch
  perl-Getopt-Long-1:2.50-4.el8.noarch                               perl-HTTP-Tiny-0.074-1.el8.noarch
  perl-IO-Compress-2.081-1.el8.noarch                                perl-IO-Socket-INET6-2.72-12.el8.noarch
  perl-IO-Socket-IP-0.39-5.el8.noarch                                perl-MIME-Base64-3.15-396.el8.x86_64
  perl-Mail-DKIM-0.54-1.el8.noarch                                   perl-Mail-SPF-2.9.0-15.el8.noarch
  perl-MailTools-2.20-2.el8.noarch                                   perl-Net-DNS-1.15-1.el8.noarch
  perl-Net-SMTP-SSL-1.04-5.el8.noarch                                perl-NetAddr-IP-4.079-7.el8.x86_64
  perl-PathTools-3.74-1.el8.x86_64                                   perl-Pod-Escapes-1:1.07-395.el8.noarch
  perl-Pod-Perldoc-3.28-396.el8.noarch                               perl-Pod-Simple-1:3.35-395.el8.noarch
  perl-Pod-Usage-4:1.69-395.el8.noarch                               perl-Scalar-List-Utils-3:1.49-2.el8.x86_64
  perl-Socket6-0.28-6.el8.x86_64                                     perl-Storable-1:3.11-3.el8.x86_64
  perl-Sys-Syslog-0.35-397.el8.x86_64                                perl-Term-ANSIColor-4.06-396.el8.noarch
  perl-Term-Cap-1.17-395.el8.noarch                                  perl-TermReadKey-2.37-7.el8.x86_64
  perl-Text-Diff-1.45-2.el8.noarch                                   perl-Text-ParseWords-3.30-395.el8.noarch
  perl-Text-Tabs+Wrap-2013.0523-395.el8.noarch                       perl-Thread-Queue-3.13-1.el8.noarch
  perl-Time-HiRes-1.9758-1.el8.x86_64                                perl-Time-Local-1:1.280-1.el8.noarch
  perl-URI-1.73-3.el8.noarch                                         perl-Unicode-Normalize-1.25-396.el8.x86_64
  perl-constant-1.33-396.el8.noarch                                  perl-libnet-3.11-3.el8.noarch
  perl-parent-1:0.237-1.el8.noarch                                   perl-podlators-4.11-1.el8.noarch
  perl-srpm-macros-1-25.el8.noarch                                   perl-threads-1:2.21-2.el8.x86_64
  perl-threads-shared-1.58-2.el8.x86_64                              perl-version-6:0.99.24-1.el8.x86_64
  pinentry-1.1.0-2.el8.x86_64                                        pinfo-0.6.10-18.el8.x86_64
  pkgconf-1.4.2-1.el8.x86_64                                         pkgconf-m4-1.4.2-1.el8.noarch
  pkgconf-pkg-config-1.4.2-1.el8.x86_64                              polkit-pkla-compat-0.1-12.el8.x86_64
  popt-1.16-14.el8.x86_64                                            prefixdevname-0.1.0-6.el8.x86_64
  procmail-3.22-47.el8.x86_64                                        protobuf-c-1.3.0-4.el8.x86_64
  psacct-6.6.3-4.el8.x86_64                                          publicsuffix-list-dafsa-20180723-1.el8.noarch
  python3-asn1crypto-0.24.0-3.el8.noarch                             python3-cairo-1.16.3-6.el8.x86_64
  python3-cffi-1.11.5-5.el8.x86_64                                   python3-chardet-3.0.4-7.el8.noarch
  python3-configobj-5.0.6-11.el8.noarch                              python3-dateutil-1:2.6.1-6.el8.noarch
  python3-decorator-4.2.1-2.el8.noarch                               python3-dnf-4.2.23-4.el8.noarch
  python3-dnf-plugins-core-4.0.17-5.el8.noarch                       python3-idna-2.5-5.el8.noarch
  python3-iniparse-0.4-31.el8.noarch                                 python3-kmod-0.9-20.el8.x86_64
  python3-pyOpenSSL-18.0.0-1.el8.noarch                              python3-pycparser-2.14-14.el8.noarch
  python3-pyparsing-2.1.10-7.el8.noarch                              python3-pysocks-1.6.8-3.el8.noarch
  python3-pyudev-0.21.0-7.el8.noarch                                 python3-pyyaml-3.12-12.el8.x86_64
  python3-rpm-4.14.3-4.el8.x86_64                                    python3-six-1.11.0-8.el8.noarch
  python3-slip-0.6.4-11.el8.noarch                                   python3-slip-dbus-0.6.4-11.el8.noarch
  python3-systemd-234-8.el8.x86_64                                   python3-urwid-1.3.1-4.el8.x86_64
  quota-1:4.04-10.el8.x86_64                                         quota-nls-1:4.04-10.el8.noarch
  readline-7.0-10.el8.x86_64                                         rootfiles-8.1-22.el8.noarch
  rpm-4.14.3-4.el8.x86_64                                            rpm-build-4.14.3-4.el8.x86_64
  rpm-build-libs-4.14.3-4.el8.x86_64                                 rpm-libs-4.14.3-4.el8.x86_64
  rpm-plugin-selinux-4.14.3-4.el8.x86_64                             rpm-plugin-systemd-inhibit-4.14.3-4.el8.x86_64
  rpm-sign-4.14.3-4.el8.x86_64                                       rust-srpm-macros-5-2.el8.noarch
  satyr-0.26-2.el8.x86_64                                            setserial-2.17-45.el8.x86_64
  sgml-common-0.6.3-50.el8.noarch                                    shared-mime-info-1.9-3.el8.x86_64
  slang-2.3.2-3.el8.x86_64                                           source-highlight-3.1.8-16.el8.x86_64
  symlinks-1.4-19.el8.x86_64                                         time-1.9-3.el8.x86_64
  timedatex-0.5-3.el8.x86_64                                         tmux-2.7-1.el8.x86_64
  tree-1.7.0-15.el8.x86_64                                           urw-base35-bookman-fonts-20170801-10.el8.noarch
  urw-base35-c059-fonts-20170801-10.el8.noarch                       urw-base35-d050000l-fonts-20170801-10.el8.noarch
  urw-base35-fonts-20170801-10.el8.noarch                            urw-base35-fonts-common-20170801-10.el8.noarch
  urw-base35-gothic-fonts-20170801-10.el8.noarch                     urw-base35-nimbus-mono-ps-fonts-20170801-10.el8.noarch
  urw-base35-nimbus-roman-fonts-20170801-10.el8.noarch               urw-base35-nimbus-sans-fonts-20170801-10.el8.noarch
  urw-base35-p052-fonts-20170801-10.el8.noarch                       urw-base35-standard-symbols-ps-fonts-20170801-10.el8.noarch
  urw-base35-z003-fonts-20170801-10.el8.noarch                       usb_modeswitch-2.5.2-1.el8.x86_64
  usbutils-010-3.el8.x86_64                                          userspace-rcu-0.10.1-2.el8.x86_64
  virt-what-1.18-6.el8.x86_64                                        words-3.0-28.el8.noarch
  xdelta-3.1.0-4.el8.x86_64                                          xdg-utils-1.1.2-5.el8.noarch
  xfsdump-3.1.8-2.el8.x86_64                                         xml-common-0.6.3-50.el8.noarch
  xmlrpc-c-1.51.0-5.el8.x86_64                                       xmlrpc-c-client-1.51.0-5.el8.x86_64
  xorg-x11-font-utils-1:7.5-40.el8.x86_64                            xorg-x11-fonts-ISO8859-1-100dpi-7.5-19.el8.noarch
  xorg-x11-server-utils-7.7-27.el8.x86_64                            xz-5.2.4-3.el8.x86_64
  xz-libs-5.2.4-3.el8.x86_64                                         yajl-2.1.0-10.el8.x86_64
  yum-4.2.23-4.el8.noarch                                            yum-utils-4.0.17-5.el8.noarch
  zip-3.0-23.el8.x86_64

完了しました!

エラーもなく、500以上のパッケージが無事に更新されました。更新完了後、再起動します。

Oracle Linuxへの移行後

再起動すると、起動メニューにさっそく Oracle Linux の文字が!

起動メニューにOracle Linux

そして起動後のコンソール画面を見ると、ここにもOracle Linuxの文字が!

コンソールにもOracle Linux

カーネルのバージョンを確認してみると、

# uname -r
5.4.17-2036.104.5.el8uek.x86_64

UEKに変更されていますね。あ、UEKというのは、Oracle Linux用の「Red Hat互換のカーネル」とのことです。

リポジトリも確認してみると、

# yum repolist
repo id               repo の名前
elrepo                ELRepo.org Community Enterprise Linux Repository - el8
ol8_UEKR6             Latest Unbreakable Enterprise Kernel Release 6 for Oracle Linux 8 (x86_64)
ol8_appstream         Oracle Linux 8 Application Stream (x86_64)
ol8_baseos_latest     Oracle Linux 8 BaseOS Latest (x86_64)
ol8_developer_EPEL    Oracle Linux 8 EPEL Packages for Development (x86_64)

変わっていますね。

これで移行作業は完了です。お疲れ様でした!

初稿:2021年3月23日

この記事をシェア

アカウントをフォロー