ONLY Mobile

音が出ないのはWindowsVistaSP1が原因っぽい

地デジ/BS/CSキャプチャカード導入にあたって、どうやらPIXELAのアプリはDVD/BDへのダビングなどはWindowsVistaしか対応していないらしく、XPではいくら録画してもHDDに置いておくだけになってしまうので、思い切って、今さらながらWindowsVistaを買ってみました。

ちょうどWindows7アップグレードチケット付きがあったので、今後Windows7にアップグレードするつもりで。

OSのインストールは特に問題なく進み、M/Bのチップセットのドライバも入れ、サウンドドライバをインストールしたところでどうもおかしな現象が発生。

サウンドドライバをインストールして再起動すると、なぜかサウンドカードが認識されていない。もう一度再起動すると、今度はきちんと認識される。さらに再起動すると、また認識されない。

オンボードのサウンドカードなので、接触などの問題はないはず。

グラボのHDMI出力ドライバが勝手にHDMI側にサウンド出力先を設定しているのかと思って、HDMIのドライバを削除してみても、症状は変わらず。

とりあえず音が出なくてもいいか、と、チューナーカードを取り付けてドライバとアプリをインストールし、アンテナ線をつながないままチューナー付属アプリを起動してみると…有効な音声出力先がない、と怒られてアプリ起動中止に。

2時間ほど格闘するも、結局原因不明のままこの日はタイムアップとなりました。

マザボやグラボ、チューナーカードのあたりで変な相性問題でも出たのか、それともVista用ドライバの何かが悪かったのか…。

もう一度Vistaのインストールからやり直してみるしかないかな(´Д`)

ちなみにマザボは、BIOSTARのP4M900-M7 SE。これにCore2Duo E6300を乗っけて、PC2-5300のメモリを2GB+1GB。HDDはSamsungのSATA-II 200GBと、HITACHIのSATA-II 1TB。

グラボは、玄人志向のRadeonHD3450が乗ってるロープロファイル対応のやつ。

チューナーカードは、地デジ/BS/CS対応のPIXELA PIX-DT012-PP0。

XPでは何の問題もなく動いていたので、Vistaにしたことが原因か、もしくはVista用ドライバあたりが怪しい…のかなぁ。

スポンサーリンク

犯人はVista SP1

ということで、翌日もWindowsVistaと格闘してみました。

原因をはっきりさせるため、チューナーカード(PIX-DT012-PP0)もグラボ(RadeonHD3450)も外し、M/BにHDDとDVDドライブだけをつないだ状態(もちろんCPUやメモリは積んでいます(笑))のみでWindowsVistaをクリーンインストール。

インストールが終了した時点では、オンボードのサウンドもきちんと認識しているよう。PCを再起動してみても、ちゃんと認識しているみたい。

一旦PCの電源を落として、グラボを挿してから起動させてみる。

Vistaが勝手にドライバをインストールしようとするけど、該当するドライバがなかったらしいのでキャンセルし、グラボについてきたドライバCDからドライバをインストールしてみる。グラフィックドライバと一緒にHDMIのサウンドドライバまで入ってしまったので、とりあえず無効にしておく。

PCを再起動させてみると…またオンボードのサウンドが認識されなくなった。どうやらグラボのHDMI出力時のサウンドドライバが入ると、オンボードのサウンドが死んでしまうらしい。XPではそんな症状がなかったので、Vista固有の問題かな。

何度か再起動させたり、電源を落としてから起動させてみたりした結果、どうやらPCの電源を入れてすぐの状態ではオンボードのサウンドが認識され、一度でもOSを再起動させると一切認識しなくなる、という状態が100%の確率で出ることがわかった。わかったけど…これはどう対策したらよいものか。

とりあえず電源を一度落とせば認識されるから、しばらくは騙し騙しで使うか、と割り切り、VistaにSP2を入れてみたところ…ぱったりとこの症状が出なくなった。何度再起動させても、きちんとオンボードのサウンドが認識されているし、正常に音も出る。

どうやら、犯人はVista SP1だった、という可能性が濃厚。

正常に動くようになったのでよかったけど、この件でより一層自分の中でのVistaに対しての嫌悪感が大きくなりました。

ちなみに、HDMI出力付きのグラボをPCに着けたままVistaをインストールすると、サウンドドライバはHDMI用しか入れてくれず、自分でオンボードのサウンドドライバをインストールしないといけないのは非常に面倒。

さて、これでやっと地デジ/BS/CSがPCで観られる!と喜んだのも束の間。今度はモニタがHDCP非対応という問題が発生。このPCにつないでいるモニタはもう6~7年前のものなので、DVIには対応しているけどHDCPには対応していなかったのでした。

部屋の配置的な事情でメインPCのモニタを使うわけにもいかないので、アウトレット商品で見つけた16,000円の22インチ液晶モニタの購入ボタンをポチッ。早く届かないかなぁ(´Д`)